سایت دانلود بازی و نرم افزار مک

روش نصب مک او اس مانتری در یک مک قدیمی

30
فروردین 1401
زمان تقریبی مطالعه این مطلب حدود 13 دقیقه
0 نظر 1126 بازدید

روش نصب مک او اس مانتری در یک مک قدیمی

مک شما برای اجرای جدیدترین مک او اس خیلی قدیمی است؟ شاید این طور نباشد! در این مقاله روش بروزرسانی مک‌های قدیمی به مک او اس مانتری با استفاده از پچر مانتری ذکر شده است. همچنین در مورد سایر نسخه‌های مک او اس نیز صحبت خواهیم کرد. با سافت‌مک همراه باشید.

-----

اپل بسیار منظم و دقیق با ارائه ویژگی‌ها و پیشرفت‌های جدید سالی یکبار سیستم عامل دسکتاپ و لپتاپ مک او اس خود را بروزرسانی می‌کند. همه‌ی اینها بسیار خوب است، اما جدیدترین نسخه‌ی مک او اس اپل، یعنی مانتری، بر روی مدل‌های مک‌بوک ایر، مک‌بوک پرو یا آی‌مک که قبل از اواخر سال 2015 عرضه شده‌اند، اجرا نمی‌شود. مک‌بوک 2016 پشتیبانی می‌شود و اگر مک مینی یا یک مک پرو 2013 داشته باشید بسیار خوش‌شانس هستید. اما در واقع اینها قدیمی‌ترین مک‌هایی هستند که می‌توانند مک او اس مانتری را پشتیبانی کنند.

حالا اگر مک یا مک‌بوک شما قدیمی‌تر از 2014 یا 2015 باشد چه باید کرد؟ رسماً این بدان معنی است که مک شما نمی‌تواند به صورت رسمی به مک او اس مانتری بروزرسانی شود؛ مگر اینکه این آموزش را دنبال کنید.

این مسئله موضوع جدیدی نیست. هنگامی که مک او اس بیگ سِر در سال 2020 عرضه شد، این سیستم عامل نیز به مجموعه‌ای از مک‌های مشابه محدود بود. اگر چه در آن زمان چند مک دیگر نیز در لیست وجود داشت، از جمله: آی‌مک 2014، مک‌بوک ایر 2013 و 2014، مک‌بوک پرو 2013 و 2014، و مک‌بوک 2015.

قبل از اینکه ادامه دهید و توصیه‌های زیر را دنبال کنید، باید یک هشدار بدهیم: دلیلی وجود دارد که اپل تصمیم می‌گیرد از سیستم عامل مک جدید در مک‌های قدیمی پشتیبانی نکند. مک‌های قدیمی‌تر اجزای لازم یا قدرت لازم برای برآورده کردن نیازهای سیستم‌های پیشرفته‌تر را ندارند. بنابراین اگر مانتری، بیگ سِر، کاتالینا، یا هر نسخه‌ی جدیدی از مک او اس را بر روی مک پشتیبانی نشده نصب می‌کنید، انتظار این را نداشته باشید که به راحتی اجرا شود.

 

آیا مک من برای بروزرسانی خیلی قدیمی است؟

در اینجا مک‌هایی که طبق گفته‌ی اپل می‌توانند مک او اس مانتری را اجرا کنند لیست شده است:

  • مدل‌های مک‌بوک از اوایل سال 2016 به بعد
  • مدل‌های مک‌بوک ایر از اوایل سال 2015 به بعد
  • مدل‌های مک‌بوک پرو از اوایل سال 2015 به بعد
  • مدل‌های مک مینی از سال 2014 به بعد
  • آی‌مک از سال 2015 به بعد
  • آی‌مک پرو (همه‌ی مدل‌ها)
  • مدل‌های مک پرو از اواخر سال 2013 به بعد

در اینجا مک‌هایی که طبق گفته‌ی اپل می‌توانند مک او اس بیگ سِر را اجرا کنند لیست شده است:

  • مدل‌های مک‌بوک از اوایل سال 2015 به بعد
  • مدل‌های مک‌بوک ایر از سال 2013 به بعد
  • مدل‌های مک‌بوک پرو از سال 2013 به بعد
  • مک‌های مک مینی از سال 2014 به بعد
  • مدل‌های آی‌مک از سال 2014 به بعد
  • آی‌مک پرو (همه‌ی مدل‌ها)
  • مدل‌های مک پرو از سال 2013 به بعد

اپل توصیه می‌کند که مک او اس کاتالینا بر روی مک‌های زیر اجرا شود:

  • مدل‌های مک‌بوک از اوایل سال 2015 به بعد
  • مدل‌های مک‌بوک ایر از اواسط سال 2012 به بعد
  • مدل‌های مک‌بوک پرو از اواسط سال 2012 به بعد
  • مدل‌های مک مینی از اواخر سال 2012 به بعد
  • مدل‌های آی‌مک از اواخر سال 2012 به بعد
  • آی‌مک پرو (همه‌ی مدل‌ها)
  • مدل‌های مک پرو از اواخر سال 2013

اپل توصیه می‌کند که مک او اس موهاوی بر روی مک‌های زیر اجرا شود:

  • مدل‌های مک از سال 2012 به بعد
  • آی‌مک پرو (از سال 2017)
  • مدل‌های مک‌بوک از سال 2015 به بعد
  • مدل‌های مک‌بوک پرو از سال 2012 به بعد
  • مدل‌های مک‌بوک ایر از سال 2012 به بعد
  • مدل‌های مک مینی از سال 2012 به بعد
  • مدل‌های مک پرو از اواخر سال 2013 (بعلاوه‌ی مدل‌های اواسط سال 2010 و اواسط سال 2012 با Metal-capable GPU توصیه شده)

مک او اس قدیمی‌تر های سیرا کمی دامنه‌ی بیشتری را شامل می‌شد. اپل اظهار داشت که به خوبی بر روی یک مک‌بوک یا آی‌مک اواخر 2009 یا جدیدتر، یا یک مک‌بوک ایر، مک‌بوک پرو، مک مینی یا مک پرو 2010 یا بالاتر اجرا می‌شود.

همچنین بخوانید: روش نصب کاتالینا در یک مک قدیمی، به روز رسانی مک.او.اس یک مک‌بوک قدیمی

شما می‌توانید نسخه‌های جدیدتر مک او اس را با استفاده از پچر در مک‌های قدیمی‌تر اجرا کنید.

انتظار نداشته باشید که همه چیز به سادگی پیش برود. در واقع باید انتظار این را داشته باشید که با مشکلاتی مواجه خواهید شد. همچنین برای این واقعیت آماده باشید که مک شما به خوبی کار نخواهد کرد و ممکن است داده‌های خود را از دست بدهید. به همین دلیل توصیه می‌کنیم که ابتدا یک نسخه‌ی پشتیبان کامل از مک خود تهیه کنید. در این مورد، مقاله‌ی کامل ما با عنوان روش تهیه نسخه پشتیبان از مک را مطالعه کنید.

به عنوان مثال، بسیاری از مک‌های قدیمی پس از نصب مک او اس بیگ سِر با اتصال وایفای مشکل داشتند. اگر به وایفای نیاز دارید، نصب نسخه‌ی پیش‌نمایش بیگ سِر و مانتری توصیه نمی‌شود.

همچنین اجرای مانتری یا مک او اس دیگری در مک پشتیبانی نشده ممکن است بر خلاف شرایط و ضوابط اپل در نظر گرفته شود.

 

روش نصب مانتری در یک مک پشتیبانی نشده

اگر مک شما بیش از چند سال قدمت دارد و سعی دارید که مانتری را بر روی آن نصب کنید، با چند مانع روبرو خواهید شد. اولین مورد این واقعیت است که بروزرسانی نرم‌افزار به شما اجازه نمی‌دهد که نسخه‌ی جدید مک او اس را نصب کنید.

با این حال، این بدان معنا نیست که نصب مانتری در یک مک قدیمی امکانپذیر نیست. در حقیقت شما فقط به یک پچ نیاز دارید. خوشبختانه پچر OpenCore Legacy Patcher برای نصب مک او اس مانتری در مک‌های قدیمی‌تر موجود است. دانلود و دستورالعمل‌های آن را می‌توانید در اینجا پیدا کنید.

فقط مراقب باشید که ممکن است Boot Camp Assistant توسط بروزرسانی خراب شود و ممکن است سایر عناصری که از آنها استفاده می‌کنید نیز دیگر کار نکنند.

توجه داشته باشید که پچرهای مک او اس نمی‌توانند جادو کنند و همه‌ی مک‌ها نیز با پچر سازگار نیستند. قبل از نصب مانتری در یک مک قدیمی، مطمئن شوید که مک شما با پچر سازگار است. شما می‌توانید لیستی از تمام مک‌های پشتیبانی شده را در اینجا مشاهده کنید.

روند بروزرسانی به نسخه‌ی جدید مک او اس در مک‌های ناسازگار به شرح زیر است:

  1. قبل از هر کاری، یک نسخه‌ی پشتیبان از مک خود تهیه کنید.
  2. ابتدا باید فایل‌های نصب نسخه‌ی مک او اس موردنظر خود را دریافت کنید: در این مورد مک او اس مانتری. شما باید اینها را با استفاده از یک مک سازگار به دست آورید. اگر در Software Update (بروزرسانی نرم‌افزار) نشان داده نشدند، می‌توانید فایل‌های نصب را از اپ استور مک دریافت کنید. حجم این فایل‌ها 12 گیگابایت است، بنابراین انتظار این را داشته باشید که دریافت آنها کمی طول بکشد.
  1. اکنون باید این فایل‌های نصب را بر روی یک فلش مموری بارگذاری کرده و فلش مموری را برای نصب مک او اس مانتری آماده کنید. در مقاله‌ی دیگری، آموزش جامع روش ایجاد یک نصب کننده بوتیبل برای مک او اس را توضیح داده‌ایم. شما می‌توانید فایل‌های نصب را در Applications پیدا کنید.
  2. در مرحله‌ی بعد شما باید نرم‌افزار پچر را دریافت کنید که اساساً فایل‌های نصب نسخه‌ی مک او اس‌ی که می‌خواهید نصب کنید را فریب می‌دهد تا باور کند که در حال نصب شدن بر روی یک مک سازگار است. می‌توانید آخرین نسخه‌ی پچری که در بالا به آن اشاره کردیم را از اینجا دانلود کنید. بر روی دکمه‌های Code و Download Zip کلیک کنید.
  1. پس از اکسترکت کردن فایل دانلودی، فایل OpenCore-Patcher.app را پیدا خواهید کرد.
  2. برنامه‌ی OpenCore-Patcher را اجرا کنید.
  3. Build OpenCore را انتخاب کنید (مگر اینکه بخواهید پچر را بر روی مک دیگری اجرا کنید، در این صورت باید Change Model را انتخاب کنید).
  4. پس از ورود به Build OpenCore، فرآیند باید به سرعت ساخته شود و سپس به منوی اصلی باز خواهید گشت.
  5. در مرحله‌ی بعدی باید از بین گزینه‌ها، گزینه‌ی Install OpenCore to USB/internal drive را انتخاب کنید. (توصیه می‌شود که بر روی یک درایو FAT32 نصب کنید).
  6. هنگامی که فرآیند ایجاد تکمیل شد، باید در حالی که کلید Option/Alt را نگه داشته‌اید، مک خود را راه‌اندازی مجدد کنید.
  7. زمانی که مک راه‌اندازی می‌شود، یک صفحه‌ی سیاه با چند گزینه درایو را مشاهده خواهید کرد. گزینه‌ی EFI Boot را انتخاب کنید.
  8. با این کار OpenCore بارگیری می‌شود. سپس باید Install macOS را انتخاب کنید. شما باید گزینه‌ی Install macOS Big Sur را در OpenCore Picker مشاهده کنید.
  9. اکنون macOS Monterey را نصب کنید.

در صورت بروز هرگونه مشکل، توصیه می‌کنیم مراحل ذکر شده در اینجا را دنبال کنید. انتظار می‌رود که بروزرسانی چند ساعت طول بکشد.

 

روش نصب بروزرسانی‌های مک او اس در یک مک پشتیبانی نشده

پس از نصب مک او اس مانتری (یا هر نسخه‌ای که انتخاب می‌کنید)، بروزرسانی‌ها به محض در دسترس بودن در Software Updates (بروزرسانی‌های نرم‌افزار) ظاهر می‌شوند. با این حال، شما نباید این بروزرسانی‌ها را نصب کنید، بلکه در بهترین حالت باید دوباره یک فلش مموری با فایل‌های نصب فعلی ایجاد کرده و بروزرسانی را به این روش نصب کنید.

 

روش نصب مک او اس بیگ سِر بر روی مک پشتیبانی نشده

نصب بیگ سر بر روی یک مک پشتیبانی نشده نیز مشکل است، اما باز هم، بدین معنی نیست که نصب بیگ سر در یک مک قدیمی امکان‌پذیر نیست. یک پچر نیز برای نصب مک او اس بیگ سر در مک‌های قدیمی‌تر موجود است. شما می‌توانید big-sur-micropatcher را از GitHub دانلود کنید.

بررسی کنید که آیا پچر با مک شما سازگار است یا خیر. این اطلاعات را باید بتوانید در صفحه‌ی پچر (لینک بالا) پیدا کنید.

روش بروزرسانی به مک او اس بیگ سر در یک مک ناسازگار به شرح زیر است:

  1. ابتدا باید فایل‌های نصب سیستم عامل را دریافت کنید. این فایل‌ها را باید با استفاده از یک مک سازگار به دست آورید. اگر در Software Update (بروزرسانی نرم‌افزار) نشان داده نشدند، می‌توانید فایل‌های نصب را از اپ استور مک دریافت کنید.
  2. اکنون باید این فایل‌های نصب را بر روی یک فلش مموری بارگذاری کنید و فلش مموری را برای نصب مک او اس بیگ سر آماده کنید. در مقاله‌ی دیگری، آموزش جامع روش ایجاد یک نصب کننده بوتیبل برای مک او اس را توضیح داده‌ایم.
  3. در مرحله‌ی بعد، باید نرم‌افزاری را تهیه کنید که بتواند فایل نصب نسخه‌ی مک او اس‌ی را که می‌خواهید نصب کنید فریب دهد و باور کند که مک سازگار است. شما می‌توانید پچری که در بالا به آن اشاره کردیم را از GitHub دانلود کنید. بر روی دکمه‌های Code و Download Zip کلیک کنید.
  1. پس از اکسترکت کردن فایل دانلودی، فایل micropatcher.sh را پیدا خواهید کرد.
  2. یک پنجره ترمینال باز کرده و فایل را کشیده و در ترمینال رها کنید. سپس دستور را اجرا کنید.
  1. اکنون مک او اس را از نصب کننده‌ی بوتیبل خود نصب کنید.
  2. در برخی موارد، پس از نصب هنوز کارهایی وجود دارد که باید انجام شود. این کارها را می‌توان در دستورالعمل big-sur-micropatcher یافت. پس از آماده‌سازی مک با فلش مموری، یک پنجره‌ی ترمینال باز کرده و دستور زیر را در آن وارد کنید.
/ Volumes / Image \ Volume / set-vars.sh

این اسکریپت بخشی از پچ برای مک او اس بیگ سر است و تنظیمات مهمی را برای بوت شدن و فایل‌های سیستم تغییر می‌دهد.

روش نصب مک او اس مانتری در یک مک قدیمی

بروزرسانی ممکن است چند ساعت طول بکشد. در مورد ما، گاهی اوقات این طور به نظر می‌رسید که نصب کننده در طول بروزرسانی از کار افتاده است. در چنین مواقعی باید همچنان منتظر بمانید، زیرا معمولاً روند نصب همچنان در حال انجام است. با گذشت زمان، ممکن است راه‌های بهتری برای بروزرسانی دستگاه پیدا شود. اما در حال حاضر، ایمن‌ترین روش برای این کار، بروزرسانی با استفاده از یک فلش مموری بوتیبل است.

 

روش اجرای مک او اس کاتالینا در یک مک قدیمی

شما می‌توانید یک macOS Catalina Patcher را از یک توسعه دهنده به نام DOSDude1 دانلود کنید. این پچ به شما این امکان را می‌دهد تا کاتالینا را در یک مک قدیمی‌تر نصب کنید.

هک کاتالینا در هر مک‌ی امکانپذیر نیست، اما بسیاری از آنها تحت پوشش قرار می‌گیرند. در اینجا می‌توانید مشاهده کنید که آیا مک شما پشتیبانی می‌شود یا خیر.

DOSDude1 یک آموزش تصویری را در وبسایت خود در اینجا ارائه داده است. ما مراحل کار را در ادامه به صورت ساده توضیح می‌دهیم، اما توصیه می‌کنیم که آموزش او را دنبال کنید.

  1. آخرین نسخه پچ کاتالینا را از اینجا دانلود کنید. (ضمن اینکه از همینجا می‌توانید به این توسعه دهنده کمک مالی هم بکنید).
  2. برنامه‌ی Catalina Patcher را باز کنید.
  3. بر روی Continue (ادامه دادن) کلیک کنید.
  4. گزینه‌ی Download a Copy را انتخاب کنید.
  5. دانلود (کاتالینا) شروع می‌شود. از آنجایی که حجم فایل تقریباً 8 گیگابایت است، احتمالاً کمی طول خواهد کشید.
  6. یک فلش مموری را به دستگاه خود وصل کنید.
  7. از میان گزینه‌ها، گزینه‌ی Create a bootable installer (ایجاد یک نصب کننده‌ی بوتیبل) را انتخاب کنید.
  8. فلش مموری حاوی نصب کننده‌ی بوتیبل را به مک‌ی که می‌خواهید بروزرسانی کنید وصل کنید.
  9. در حالی که کلید Option/Alt را نگه داشته‌اید، مک را راه‌اندازی مجدد کنید. این کار باعث می‌شود که مک در Startup Manager (مدیریت راه‌اندازی) باز شود.
  10. درایو نصب کننده‌ی بوتیبل را انتخاب کرده و کلید Enter را فشار دهید.
  11. اکنون مک شما باید در حالت Recovery (بازیابی) باز شود.
  12. گزینه‌ی Reinstall macOS (نصب مجدد مک او اس) را انتخاب کرده و منتظر بمانید تا نسخه‌ی جدید مک او اس نصب شود.
  13. پس از اتمام نصب، باید مک را مجدداً در حالت Recovery ری‌استارت کرده و درایو حاوی نصب کننده‌ی بوتیبل را انتخاب کنید.
  14. اکنون macOS Post Install را انتخاب کنید تا پچ‌های موردنیاز بر روی مک شما نصب شود و کاتالینا بتواند کار کند.
  15. هنگامی که پچ‌ها اعمال شدند Force Cache Rebuild (بازسازی اجباری کش) را انتخاب کنید.
  16. حالا ری‌استارت کنید.
  17. پس از راه‌اندازی مجدد، مک شما باید در یک نسخه‌ی کاملاً فعال شده از مک او اس کاتالینا بوت شود.

اگر نسخه‌ای از مک او اس را اجرا می‌کنید که مربوط به های سیرا یا موهاوی است، باید هارد دیسک خود را به APFS فرمت کنید.

 

روش اجرای مک او اس موهاوی در یک مک قدیمی

همانند مک او اس کاتالینا، DOSDude1 یک ابزار پچ دیگر نیز نوشته است که به شما این امکان را می‌دهد تا مک او اس موهاوی را بر روی یک مک قدیمی نصب کنید.

شما می‌توانید Mojave Patch Tool را از اینجا دانلود کنید.

 

روش اجرای مک او اس های سیرا و نسخه‌های قدیمی‌تر در یک مک قدیمی

DOSDude1 پچ مشابهی نیز برای های سیرا (High Sierra) و نسخه‌ی قبلی آن سیرا (Sierra) نوشته است. با نصب پچ می‌توانید به مدل‌های اولیه 2008 برگردید. بعید به نظر می‌رسد که به درستی اجرا شود، به همین دلیل است که اپل توصیه می‌کند که از این روش اقدام نکنید. اما باید بتوانید به عملکرد قابل تحملی دست پیدا کنید.

 

چرا نباید مک او اس جدید را بر روی یک مک قدیمی نصب کرد؟

ما به مبتدیان فناوری توصیه می‌کنیم که این راه‌حل را انجام ندهند. انجام این کار به درجه‌ی متوسطی از تخصص در فناوری نیاز دارد.

به خاطر داشته باشید که ما مخالف توصیه‌ی رسمی اپل در این مورد هستیم. یعنی اگر مشکلی پیش بیاید - و چنین اتفاقی همیشه با نصب یک سیستم عامل امکانپذیر است، حتی اگر از نرم‌افزار رسمی استفاده می‌کنید - بعید است که گارانتی بتواند شما را نجات دهد. البته بعید است که مک 2008 شما تحت پوشش گارانتی باشد، بنابراین احتمالاً چندان جای نگرانی نیست.

قبل از ادامه‌ی کار، یک نسخه‌ی پشتیبان از مک خود تهیه کنید. و دو نکته‌ی دیگر را نیز در نظر داشته باشید.

در برخی مواقع، این امکان وجود دارد که اپل این هک را اصلاح کرده و از کارکرد آن در آینده جلوگیری کند. بنابراین اگر مشتاق و راضی هستید که روبرو شدن با خطرات و مشکلات ارزشش را دارد، پس این کار را انجام دهید.

 

 

مطالب مشابه
ثبت نظر جدید

هنوز نظری برای این نسخه از نرم افزار ثبت نشده است، اولین نفری باشید که نظر ارسال میکند.

تیم کوک
میان «علاقه‌مندی به کار کردن» و «علاقه‌مندی به کار» تفاوت فاحشی وجود دارد.

برنامه‌ها

بازی‌ها

آموزش‌ها

اخبار
SPACE^